因为要用spring框架,所以打算装上方便的插件spring ide。

怎么完成这个安装?

一、流程

(1)如果没eclipse的话,干脆直接去装spring官方的sts吧

1

下载地址:http://spring.io/tools/sts/all/

首先要注意java是多少位的,如果不一致是运行不了的。

cmd输入 java -version ,如果有java X64标识的就是X64版本的,没有就是X32版本的了,千万要装对应的版本,如果你不想遇到问题重来的话…

如果你决定装sts了,那么接下来的文章也就不用看下去了…

(2)我用惯了eclipse了,谁还去装sts啊

注意:这里需要更正一点,如果网速可以,还是尽量勾上联网更新的选项。特别是直接下载了sts的插件包,然后在本地安装的情况下,一定要勾选联网更新,否则会导致安装问题。

新的安装方式在这里:

环境 eclipse 无法安装sts插件的问题

1.spring官网寻找依赖

首先是查看你的eclipse的版本,在eclipse里面的 help -> about eclipse -> 单击eclipse图标,可以看到eclipse platform的详细版本,记住你的版本,接下来要用到。

还是来到这里:http://spring.io/tools/sts/all/,找到eclipse版本的链接:

2

复制到eclipse里的Install new Software里,只选择后缀为spring ide的选项。

请记住不要选联网更新的勾,这样会更快。

慢慢等待运行完成就可以了。

2.marketplace搜索依赖

直接在eclipse的marketplace里搜索spring ide,基本上就能找到了,安装即可。marketplace打开可能有点慢,搜索也有点慢,被墙就是这么残酷。

3.eclipse官方插件网站

百度关键词 eclipse spring ide,找到eclipse的官方插件页面:

然后把这个install按钮拖到eclipse上,就可以开始安装了,其实有点像方法二。

三个方法任君选择…但是我能保证这三个方法装上的spring ide是一样的,没有什么区别。

(3)你可能会遇到的问题

如果没有用直接安装sts这种简单粗暴的方法,那么有很大可能会遇到以下问题:

就是 慢!

你需要等很久,而你的eclipse有可能会莫名其妙的崩溃。你很可能会发现进度条卡在一个连接上,dl-ssl.google.com。这就意味着你需要往下看。

因为google被墙,需要换个google解析的地址来完成下载。

1.黑科技,翻墙

会翻墙,会编程,那么你肯定早就把以上所有问题解决了…

2.百度 google hosts

进入随便一个页面,查看最新google hosts。

ctrl+f 搜索 dl-ssl.google.com。

建议先cmd ping一下,不然等下发现是个失效的地址…那么你不但没有解决问题,还引发了更多的问题…

如果能ping通,那么把这行东西 220.255.2.153 dl-ssl.google.com 复制下来等下用。

如果哪天这个地址失效了,请重复以上步骤,找到一个能ping通的为止。

ps.如果一些不良google hosts网站叫你下载什么奇怪的程序,或者叫你捐助,或者叫你往hosts里加一些奇怪的网站内容,请无视之。

不然后果很严重。记住要加的只是dl-ssl.google.com而已。

3.修改hosts文件

打开C:\Windows\System32,搜索hosts:

1

用记事本什么的打开,把刚才复制的东西粘贴到末尾,保存。

4.继续下载吧

如果步骤正确,下载速度应该会比较快,但是依然取决于你的网速。

(5)装完了会是什么样子的?我去哪里找这个东西?

装完了eclipse会提示重启,重启之后你就会在欢迎界面见到这个:

什么,你不会说不知道这个欢迎界面在哪里打开吧…在help选项卡里,第一个就是。

二、总结

用半个小时完成的工作,记录一下吧,希望能帮更多人迅速解决开发环境的问题。

发表评论

电子邮件地址不会被公开。 必填项已用*标注