今天上午遇到的一个坑,记录一下

一、问题场景

之前我的开发环境出问题,版本也很旧,所以打算换新的环境。结果一换就出问题了。

因为要写spring,所以打算装个sts插件,结果死活都装不上。

我的安装步骤是这样的:

  1. 去eclipse官网下载最新的neon1,解压安装好。
  2. 去spring官网下载对应eclipse版本的sts插件。
  3. 本地安装sts插件。为了加快安装速度,跳过联网检查更新,我选择断开网络(之前装sdk时在网上学到的方法,因为无法联网,就会减少检查的时间)。
  4. 然后直接安装,没有勾选安装步骤中的自动更新。
  5. 安装完后重启eclipse。

那么问题来了,我重启之后根本没有看到spring的选项,那就是安装失败了。

二、尝试解决

一开始我还以为是版本对应不上,看了下eclipse版本的信息,确实是4.6.1没错…

我又去看了下sts插件的版本信息,也是4.6.1没错,那就不是版本不对应的问题了…

之后我以为是安装步骤中少勾选了什么东西,然后重新装了一遍,也是完全没有效果,依然没有spring的选项。

三、解决方法

在安装的时候,需要联网(最好翻墙),并且勾选获取更新,就可以正确安装了。

qq%e6%88%aa%e5%9b%be20161208111109

看来问题出在联网自动更新上,如果禁止获取更新,那么安装插件的时候容易出问题。当然,此选项很可能导致安装速度很慢,没办法,只能翻墙或者替换国内镜像尝试解决。

四、总结

不知道发生了什么…,我现在还是懵逼的。

1 对 “环境 eclipse 无法安装sts插件的问题”的想法;

发表评论

电子邮件地址不会被公开。 必填项已用*标注